Warning: ob_start() [ref.outcontrol]: output handler 'ob_gzhandler' cannot be used after 'mb_output_handler' in /home/steams6/public_html/forum/index.php on line 136
Non-functioning Amerec Sauna w/DC60 - Steam Sauna Bath Forum
HomeHelpSearchLoginRegister

Welcome, Guest. Please login or register.
Did you miss your activation email?
June 21, 2018, 03:39:49 AM
Username:
Password: 


Login with username, password and session length
Search

Stats
1,919 Posts in 744 Topics by 3,249 Members
Latest Member: Dunk_The_Lunk
+  SteamSaunaBath User Forum
|-+  Sauna
| |-+  Technical Support
| | |-+  Non-functioning Amerec Sauna w/DC60
« previous next »
Pages: [1] Print
Topic: Non-functioning Amerec Sauna w/DC60  (Read 7709 times)
nysau
Newbie
*
Posts: 1


« on: January 18, 2015, 02:42:43 PM »

Hello - I have not used my sauna (with Amerec DC60 control and Digital series heater) in some time. I have a master power switch and the DC60 control on the exterior of the sauna, and normally when the switch is flipped on the DC60 display lights up. Now when I flip the switch, the DC60 is dead. I have checked my breaker box and don't believe that is the issue.

Is there a list of things to try in this case? Is it definitely the DC60 that's dead, or could it be any number of things? (for example, would a bad temp sensor or other problem keep the DC60 from lighting up as well?)

Thanks so much for any guidance on troubleshooting/culprits.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Copyright 2003-2018 © Steam Sauna Bath is a division of Bathing Brands, Inc. All Rights Reserved.