HomeHelpSearchLoginRegister

Welcome, Guest. Please login or register.
Did you miss your activation email?
December 08, 2016, 08:05:07 AM
Username:
Password: 


Login with username, password and session length
Search

Stats
1,853 Posts in 716 Topics by 3,217 Members
Latest Member: 4cfea
+  SteamSaunaBath User Forum
|-+  Steam Shower
| |-+  Technical Support
| | |-+  Steamist SM36 non start
« previous next »
Pages: [1] Print
Topic: Steamist SM36 non start  (Read 2099 times)
martinperry
Newbie
*
Posts: 1


« on: September 21, 2012, 04:39:47 AM »

Hi, Greetings from the UK
I have an old SM36. This is refusing to start up (has been the same for a few years, kids finally old enough to try and fix it!!)
The fuse is good, and power LED on.
When I press the test button, the top green LED flicks on momentarily, then nothing. The top amber LED very occasionally joins in, but again, only stays on for milliseconds. Same happens irrespective of control connected or not, same with probe and solenoid.
Any suggestions? My suspicion is a bad board.
For reference, boars is a LLc-1300 rev 01
Thanks
Logged
Bernard
Global Moderator
Hero Member
*****
Posts: 1,126



« Reply #1 on: September 25, 2012, 08:21:07 PM »

Greetings!
Is your steam bath generator manufacturered by Steamist?  The electronics you describe seem to suggest so, however; the model number is not exact.  Steamist made an SM46 and SM79.  If you could verify the model number and reply with the serial number of the steam bath generator, I can ensure your success.

Thanks!
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Copyright 2003-2016 © Steam Sauna Bath is a division of Bathing Brands, Inc. All Rights Reserved.