Welcome, Guest. Please login or register.
Did you miss your activation email?
October 28, 2016, 06:38:31 PM

Login with username, password and session length

1,852 Posts in 715 Topics by 2,877 Members
Latest Member: Ryan H
+  SteamSaunaBath User Forum
|-+  Steam Shower
| |-+  Technical Support
| | |-+  broken steamist sm-46
« previous next »
Pages: [1] Print
Topic: broken steamist sm-46  (Read 1709 times)
Posts: 1

« on: January 31, 2012, 05:48:44 PM »

I have a steamist sm-46 which quit working. It had one blown fuse, a burnt 10k ohm resistor, a questionable diode and another questionable 10k ohm resistor. I replaced all of them. It still would not work. I ohmed the the white wires going to the 1500 watt heating element and got 35 ohms. I ohmed the black wires going to the 4500 watt heating element and got 10 ohms. The red led goes on when there is power applied. When the control is turned on two things happen. One, the green led lights up (saying that it is turned on). Two, the yellow led turns on (saying power is being applied to the heating elements) and then it immediately turns off. Does anyone have any suggestions to fix this thing?
Global Moderator
Hero Member
Posts: 627

« Reply #1 on: February 01, 2012, 07:48:28 AM »

Thank you for all the detail.  It is very helpful.
We checked with a Tech at Steamist and from what you are describing it sounds like you need a new pc board and water probe.  The unknown is whether you also have a control issue.

You can purchase these items by calling us at 800-707-2862.
Parts are non-returnable and need to be verified by one of our associates.  Mention that Jennifer verified you already.
Here are links to the items on our web site.
PC Board
Water Probe
Pages: [1] Print 
« previous next »
Jump to:  

Copyright 2003-2016 © Steam Sauna Bath is a division of Bathing Brands, Inc. All Rights Reserved.