SteamSaunaBath User Forum

Steam Shower => Technical Support => Topic started by: mitch medigovich on October 12, 2013, 08:47:51 AM

Title: SM-5 Not producing steam
Post by: mitch medigovich on October 12, 2013, 08:47:51 AM
Greetings - I have an SM-5 with 5KW.  I pushed the start button on the control pad and heard the usual start up for about 3 seconds, then nothing.  I reset the time, then temp, then pushed the off button.  Waited 4-5 min tried again and nothing.  Then went to my breaker panel, shut the system off, waited about a minute, flipped the breaker back on, no response from the generator. The control pad illuminates with a time and temp (timer is actively counting down the minutes), but again no response.

I opened the pressure relief valve, but nothing came out (probably because the unit is not heating).  Cold water intake is cold as usual, steam line is also cold of course because there is no water boiling.

New Information:  Circuit board looks good.  In line .5 fuse good, Red led working,  Pressed test switch, green led on.  Control panel in steam room communicating. Still no action from the unit.  Amber light for heat not on. 

Suggestions please?


Title: Re: SM-5 Not producing steam
Post by: Misty on October 16, 2013, 12:22:29 PM
Based on your description of the issue, it sounds like something electrical.  I would recommend having a technician inspect and troubleshoot the unit.  If you do not have a contractor that you are confident in, you can request a Service Affiliate by completing our SteamSaunaBath Service Request Form (