Welcome, Guest. Please login or register.
Did you miss your activation email?
October 21, 2016, 04:05:18 AM

Login with username, password and session length

1,851 Posts in 714 Topics by 2,830 Members
Latest Member: vntrubin
+  SteamSaunaBath User Forum
|-+  Steam Shower
| |-+  Technical Support
| | |-+  Steamist SM36 non start
« previous next »
Pages: [1] Print
Topic: Steamist SM36 non start  (Read 1992 times)
Posts: 1

« on: September 21, 2012, 04:39:47 AM »

Hi, Greetings from the UK
I have an old SM36. This is refusing to start up (has been the same for a few years, kids finally old enough to try and fix it!!)
The fuse is good, and power LED on.
When I press the test button, the top green LED flicks on momentarily, then nothing. The top amber LED very occasionally joins in, but again, only stays on for milliseconds. Same happens irrespective of control connected or not, same with probe and solenoid.
Any suggestions? My suspicion is a bad board.
For reference, boars is a LLc-1300 rev 01
Global Moderator
Hero Member
Posts: 1,126

« Reply #1 on: September 25, 2012, 08:21:07 PM »

Is your steam bath generator manufacturered by Steamist?  The electronics you describe seem to suggest so, however; the model number is not exact.  Steamist made an SM46 and SM79.  If you could verify the model number and reply with the serial number of the steam bath generator, I can ensure your success.

Pages: [1] Print 
« previous next »
Jump to:  

Copyright 2003-2016 © Steam Sauna Bath is a division of Bathing Brands, Inc. All Rights Reserved.