HomeHelpSearchLoginRegister

Welcome, Guest. Please login or register.
Did you miss your activation email?
December 09, 2016, 11:27:30 AM
Username:
Password: 


Login with username, password and session length
Search

Stats
1,853 Posts in 716 Topics by 3,228 Members
Latest Member: Stanleylog
+  SteamSaunaBath User Forum
|-+  Steam Shower
| |-+  Technical Support
| | |-+  Amerec generator with K30 control missing the temperature sensor
« previous next »
Pages: [1] Print
Topic: Amerec generator with K30 control missing the temperature sensor  (Read 1414 times)
Michael
Newbie
*
Posts: 24



« on: May 10, 2012, 03:49:38 PM »

One of my customers has an embarrassing problem. She has a 17 year old AK unit with the K30 control. She had her bath remodeled recently with all new Travertine. Looks great but somehow the installed the marble and covered up wherever the temperature sensor was. So my question is will the generator and control work without the temperature sensor being plugged in?
Logged
Earl
Steam Bath Specialist
Hero Member
*****
Posts: 500



« Reply #1 on: May 10, 2012, 04:02:48 PM »

I have some good and bad news for you. The K30 control will not turn on the generator without having a temperature sensor plugged in. However if you don't mind not being able to control your temperature the machine will still function as long as the sensor is plugged in. If you still have the original cable plugged in and the sensor is still in 1 piece somewhere it will work Or you can order a new cable and sensor and plug that in and just leave it if you don't want to add another hole in the wall. You now will have a simple on/off control.
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Copyright 2003-2016 © Steam Sauna Bath is a division of Bathing Brands, Inc. All Rights Reserved.